Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 25, 2026 - 22:00 UTC
Scheduled
The Block Aero platform will be unable to process updates while its weekly backup is taking place. Reading and queries will be unaffected. This process will not take more than 1.5 hours.
Posted Apr 17, 2026 - 05:13 UTC
This scheduled maintenance affected: Block Aero UI and Block Aero API.