Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 18, 2026 - 09:00 UTC
Scheduled
During this maintenance window, we will be performing extensive upgrade of the underlying infrastructure of the platform, which requires us to take portions of the UI and API down. This upgrade will take approximately 8 hours to perform.
Posted Apr 17, 2026 - 05:12 UTC
This scheduled maintenance affected: Block Aero UI and Block Aero API.